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Concepts

GDigiDoc is a GUI program for creating, editing and verifying digitally signed
documents. The name GDigiDoc stands for “GNU Digitally signed Documents”.
GDigiDoc is based on the DigiDoc (also known as OpenXAdES) C library. More
information on this library can be found on OpenXAdES website. DigiDoc files are
XML files and the signatures follow XMIL-DSIG and XAdES (ETSI-TS 101 903)
specifications. However one can sign any kind of data by including it in Base64
encoding in an XML document. A digitally signed document is actually a container
containing one or more data files and one or more signatures. All signatures must
sign all data files. Thus after adding the first signature you can no longer add,
modify or remove data files. A data file can contain the original file directly (if it
was an XML or text file), in Base64 encoding (if it was in some binary format) or a
reference to an external “DETATCHED” file.

This library supports only OpenXAdES file format. OpenXAdES format is based on
XAdES and adds a general XML container. This enables the library to create
digitally signed documents, that contain both many data items and many
signatures.

XAdES

The library supports RSA-SHA1 signatures. DigiDoc library includes functions for
accessing smartcards for signature operations using a PKCS#11 driver. Another
version of this library is available on Microsoft Windows platforms in form of a
COM component - DigiDocl.ibCOM. The latter uses Microsoft CSP API for
accessing smartcards. There is also a version of this library - JDigiDoc - written in
the Java programming langage.

In order to use this application you must have a smartcard with some RSA keys
and a card-reader attached to your computer. You need also drivers for your card
reader and PKCS#11 driver for your card type. How to install these is documented
below.

In Estonia digital signatures are considered equal to handwritten signatures.
However if longtime proof and validity is requred, then one must add an OCSP
confirmation to the signature. This OCSP is a signed confirmation that the signers



certificate was valid at the time of signing. OCSP confirmations are issued to all
Estonian ID cards. If you don't have one then you can still use the program by
adding your certificate to Estonian OCSP responders demo version here:
http://www.openxades.org/tryitout.html. Such confirmations are issued by the
demo-responder and they have no legal status but this enables you to try the
software. Offcourse you can also use the software to read existing digitally signed
documents. You don't need a cardreader and smartcard for that.

Installation

GDigiDoc uses GTKmm API for the popular GTK+/GNOME environment. It will
work also under KDE, but you must install GTK+ and GTKmm. GDigiDoc uses
libdigidoc library for handling digitaly signed documents. This library in turn uses
OpenSSL for cryptography, LibXML2 for XML parsing and OpenSC for smartcard
access. OpenSC library in turn needs the PCSC-lite smartcard daemon.

GDigiDoc

GTKmm LibXML2 | OpenSSL || OpenSC

GTK+ PCSC-lite

X-Windows/Win32

GDigiDoc source code can be downloaded from the projects download page at
SourceForge.net: http://sourceforge.net/projects/gdigidoc.

Installing GTKmm

Installation instructions for GTKmm can be found here:

http://www.gtkmm.org/download.shtml. There are binary packages for Debian and
also for RPM based distributions like RedHat and Mandrake. Unofficial RPM-s for

Fedora Core2 can be found here: http://www.poolshark.org/fc2.html. Binary
packages for Win32 environment can be found here:

http://www.pcpm.ucl.ac.be/~gustin/win32 ports. Offcourse you can also download
the source from GTKmm home and compile it but that takes a lot of time.

Installing PCSC-lite

Download the newest PCSC-lite from here:
https://alioth.debian.org/project/showfiles.php?group_id=1225.

Install it like that:

# ./configure

# make



# make i nstal

This installs the pcscd daemon to /usr/local/sbin and the libraries to /usr/local/lib.
You must add /usr/local/lib path to /etc/ld.so.conf if you haven't done it already
and then run ldconfig. An alternative would be to use

# ./configure —prefix=usr --sysconfdir=/etc

Then you need to create startup skripts and register pcscd to start automatically
when you start the computer. PCSC-lite daemon can't do anything without a driver
for your card reader. You can probably find a driver for your card reader from
here: http://www.linuxnet.com/sourcedrivers.html. There is also an earlier version
of PCSC-lite and RPM-s for RedHat and Mandrake. For some readers you can find
binary packages but most come in form of source code. Don' forget to register the
card reader in /etc/reader.conf. Some companies have developed Linux drivers for
their card readers and you can download the driver from the companys website.
Here are some sites where you can find more info about cardreaders and Linux:

http://www.konsultant.ee/mod.php?mod=userpage&menu=110101&page_id=1
7

http://www.id.ee/pages.php/030211?foorum=3

http://martin.paljak.pri.ee./esteid/

Installing OpenSC

PCSC-lite and cardreaders driver provide means to communicate with the card
reader device. So you can send and read data to/from any cards in the device. In
order to have the smartcard execute some command you have to know it's
command syntax. This is what a PKCS#11 driver does for you. It creates an
abstraction layer that enables a programm to communicate with any smartcard
provided that you have a PKCS#11 driver for this card. For Estonian and Finnish
ID cards one can use the OpenSC library for this purpose (http://www.opensc.org).
A specific version of this library for Estonian ID card is available here:
http://martin.paljak.pri.ee./esteid/. You can find here also instructions how to
install OpenSC and test it. Download the source code and do:

# ./configure --prefix=/usr --sysconfdir=/etc --with-pcsclite=/usr

# make
# make install

Make sure you register the directory with PKCS#11 driver (e.g. /usr/lib/pkcs11/ or
/usr/local/lib/pkcs11/) in /etc/ld.so.conf and run ldconfig. Then you can test it by
registering opensc-pkcs11.s0 as a new security device driver in Mozilla/Netscape
and try accessing some website that requires authentication. For example
https://sk.ee/cgi-bin/tervitus. You can find links to websites using smartcard
authentication here: http://www.id.ee/pages.php/030207,157.

Installing libdigidoc

GDigiDoc uses libdigidoc. Grab the newest libdigidoc from the same site you



downloaded gdigidoc (e.g. http://www.sourceforge.net/projects/gdigidoc). Install
the library like that:

# ./configure --prefix=/usr --sysconfdir=/etc
# make
# make install

This library comes with a small testprogramm - digidoc — that provides all the
same functionality as gdigidoc, except that it's a command-line program. This
utility helps you to verify that libdigidoc has been properly installed. Using and
configuring libdigidoc has been documented below.

Installing GDigiDoc

Download gdigidoc's latest version from the projects site at SourceForge.net
(http://www.sourceforge.net/projects/gdigidoc) and install it like that:

# ./configure --prefix=/usr --sysconfdir=/etc
# make
# make install

Then you could create a launcher for GDigiDoc on your GNOME panel and use the
provided id-logo.png for icon.

Using GDigiDoc

If you succeded in installing PCSC-lite, cardreader driver and OpenSC, which you
could verify by registering the PKCS#11 driver in Mozilla, then it's now time to
check if libdigidoc has been properly installed and then try using gdigidoc.

Configuring libdigidoc

Libdigdoc uses the global configuration file - /etc/digidoc.conf and a user-specific
configuration file ~/.digidoc.conf. In the global configuration file you can find the
following entries:

# CA certificates — configured properly for Estonian |ID cards.
CA_CERTS=4

CA CERT _1=/usr/local /share/certs/JUUR- SK. PEM cer
CA CERT_1 CN=Juur - SK

CA CERT _2=/usr/l ocal / share/ certs/ESTElI D- SK. PEM cer
CA_CERT_2_CN=ESTEI D- SK

CA CERT_3=/usr/local /sharel/ certs/ TEST- SK. PEM cer
CA_CERT_3_CN=TEST- SK

CA CERT_4=/usr/ | ocal / share/ certs/ KLASS3- SK. PEM cer
CA_CERT_4_CN=KLASS3- SK

CA CERT_PATH=/ usr /| ocal / share/ certs



# Default file format and version
DI A DOC_FORMAT=DI G DOC- XM_
DI G DOC _VERSI ON=1. 3

# Usabl e PKCS#11 drivers and the default driver

DI d DOC_DEFAULT_DRI VER=2

DI G DOC_DRI VERS=2

DI G DOC_DRI VER_1_NAME=EYP dri ver

Dl G DOC DRI VER 1_DESC=Eesti Yhispanga | oodud |ID kaardi PKCS#11 ohj urprogranmm
DA DOC DRIVER 1 FILE=/usr/local/lib/esteid-pkcsll.so

DI G DOC_DRI VER _2_NAME=OpenSC

Dl A DOC DRI VER 2 DESC=(penSC baasi| | oodud PKCS#11 ohj ur progranmm

DA DOC DRI VER 2 FI LE=/usr/local /i b/pkcsll/ opensc-pkcsll. so

# default slot id for signature key — configured for Estonian |ID cards!
DI G DOC_SI GNATURE_SLOT=1

# OCSP responders certficates — configured for Estonian ID cards and “deno-
responder”

DI G DOC_OCSP_RESPONDER_CERTS=3

DI G DOC_OCSP_RESPONDER CERT _1=/usr/1ocal / share/ certs/ ESTEI D- SK OCSP
RESPONDER. PEM cer

DI G DOC_OCSP_RESPONDER_CERT_1 CN=ESTEI D- SK OCSP RESPONDER

DI G DOC_OCSP_RESPONDER CERT 1_CA=ESTEI D- SK

DI d DOC_OCSP_RESPONDER _CERT 2=/ usr/ | ocal / share/ certs/ TEST- SK OCSP RESPONDER. pem cer
DI G DOC_OCSP_RESPONDER CERT 2 CN=TEST- SK OCSP RESPONDER

DI G DOC_OCSP_RESPONDER CERT 2 CA=TEST- SK

DI A DOC_OCSP_RESPONDER _CERT_3=/usr /1 ocal / share/ cert s/ KLASS3- SK OSCP
RESPONDER. pem cer

DI G DOC_OCSP_RESPONDER_CERT_3_CN=KLASS3- SK OCSP RESPONDER

DI G DOC_OCSP_RESPONDER_CERT_3_CA=KLASS3- SK

# OCSP responder URL

Dl d DOC_OCSP_URL=http://ocsp. sk. ee

# optional HTTP proxy — change this !

DI A DOC_PROXY_HOST=pr oxy. your host. com

DI G DOC_PROXY_PORT=8080

Global configuration file contains entries that are usually the same for all users of

your computer. User-specific configuration file contains entries for the given user.
Such entries allways override the global configuration file entries.



# Your PKCS#12 token file and password required to access the OCSP responder.
# you can get this PKCS#12 token from here: http://ww. sk. ee/ pages. php/ 02020504
# Change this!!!

Dl G DOC_PKCS_FI LE=<pkcs12-t oken-fi | ename- and-ful | - pat h>

Dl G DOC_PKCS_PASSWD=<pksc12-t okens- passwor d>

Dl A DOC_OCSP_URL=http://ocsp. sk. ee

# Since gdigidoc stores it's configuration entries in the users configuration
# file you can find here also the followi ng entries:

# Signers address & manifest npde: O=ask before signing, 1=none, 2=use these val ues
MANI FEST_MCDE=0

# default entries for signers address and nanifest.

Dl d DOC_ROLE_MANI FEST=I agree with this docunent...

DI G DOC_ADR_COUNTRY=Eest i

DI G DOC_ADR_STATE=Har j unaa

DI d DOC_ADR CI TY=Tal |l i nn

Dl G DOC_ADR_ZI P=12918

# Flag — use HTTP proxy or not

USE PROXY=TRUE

# Flag — sign OCSP requests or not. In general you allwas need to sign the

# OCSP requests unless you have a specific agreement with the service provider
SI GN_OCSP=TRUE

Digidoc utility

The libdigdoc library comes with a small utilityprogramm - digidoc - that provides
access to most libdigidoc functions. You can use it to create, read, modify, verify
and sign digitally signed documents on OpenXAdES format.

1. Displaying help - Use “digidoc -help” or “digidoc -?”

2.Creating a new document - Use “digidoc -new [format] [version]”. Default
format and version are taken from the configuration file(s) if omitted. This
command is optional. For example if you add a data-file using the -add
command and there is currently no digidoc in session then a new digidoc is
created implicitly.

3.Adding a data file — Use “digidoc -add <file-name> <mime-type> [<content-
type>] [<charset>]". Default content type and charset are taken from the
configuration file(s) if omitted.

4.Verifying signatures - Use “digidoc -verify”
5.Reading digidoc files - Use “digidoc -in <filename>"
6. Writing digidoc files - Use “digidoc -out <filename>"



7.Signing - Use “digidoc -sign <pin> [<manifest>] [<city> <state> <zip>
<country>]". Default values for manifest and signers address are taken from
the configuration file(s).

8. Extracting a data-file — Use “digidoc -extract <doc-id> <file-name>
[<charset>] [<file-name-charset>]".

Commands can be combined to execute more complicated tasks. For example:
- Read a digidoc file from the disk and verify all signatures:

# digidoc -in <filenane> -verify

- Create a new document in 1.1 format, add a PDF file, sign it and verify

# digidoc -new DIG@ DOC-XM. 1.1 -add nydoc. pdf application/pdf -sign <pin> “l agree
with the contract terns” -out nydoc.ddoc -verify

- Read an existing document, add a signature, verify and write in a new file

# digidoc -in nydoc.ddoc -sign <pin> “l reject this proposal!” -out nydoc2. ddoc
-verify

- Read an existing document and extract one of the data-files
# digidoc -in nydoc.ddoc -extract DO nydoc?2. pdf

GDigiDoc

Start GDigiDoc by invoking gdigidoc or clicking on the launcher icon on your
GNOME panel. The programs main window has two panels.
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The upper panel displays a list of data-files in the current digidoc document and
the lower panel displays the signatures. To view this we have the read in a digidoc
document using the File -> Open menuitem.

GDigiDoc - tartu tallinn_

leping.ddoc

File Edit [ZiHelp

D &5 3 ]

Mew Open Save Sign
Files
[Filename |Size  |Mimetype

| Tartu ja Tallinna koostooleping.doc 44544 application/msword

rSignatures

Signer Status
;ﬁ ;&NSIP,ANDRUSJSEIDDIETEE ‘u’.;—z.lid
@ SAVISAAR.EDGAR,35005310259 Valid

L i
Now we see a the name of the digidoc file on the titlebar and a list of datafiles and
signatures. All valid signatures have a green icon and invalid ones have a red icon.

To create a new digidoc document, use the File -> New menuitem. This resets the
lists and you can start adding new data-files. To add a data-file, select the Edit ->
Add file menuitem.

New Folder || Delete File | Rename File

/home/veikojprojects/DigiDocService/java %

Folders [Eiles

[/ [ creatediocisp
of createddoctljsp
ee/ - datafileinfo jsp
gfx/ datafileinfotl.jsp
META-INF/ dds_error.jsp
'WEB-INF/ documents.jsp

+ | documentstl.jsp -
Selection: /homefveiko/projects/DigiDocService/java

X cancel ‘ ok




The new file will be added to the list of data-files. You can remove files by
selecting the desired file from the list and using the Edit -> Remove file menuitem.
You cannot add or remove files if the document has been signed. Then you must
remove all signatures before making any modifications to the document.
Extracting data-files can be done my selecting the desired file from the list and
using the Edit -> Extract file menuitem. A dialogbox will ask for a new filename
and thus enables you to pick another directory where to store the file. Now you
can open the file in a suitable program.

To sign the document select the Edit -> Sign menuitem or click on the Sign icon
on the toolbar. Depending on the settings for signers address and manifest in the
configuration file a dialogbox might pop up and display the default values for
signers address and manifest.

GDigiDoc RoleAndAdr

4

Role / Manifest:

Country: Eesti
State: Harjumaa
City: Tallinn

Postal code: 12918

e

@9@( & Cancel

You can change the default values and continue adding a new signature or cancel
the operation. Then a dislogbox will appear where you can enter your signature
pin.

PINZ: |

l QQQK ¥ cancel

On Estonian ID cards this is allways the “PIN2”. GDigiDoc will now add the
signature, request for OCSP confirmation and update the siganture panel. For
removing the signature select the desired signature and use the Edit -> Unsign
menuitem.

Both panels have context-sensitive menus that you can display by right-clicking on
the datafile or signature item. These menus provide quick access to the
corresponding Edit menu items. For example to view detailed data-file info, select
the desired file from the upper panel, righ click on it and select “Info”.



DataFile Info )
Item Value =
Id Do
File name Tartu ja Tallinna koostooleping.doc
Mime type application/msword
Content type EMBEDDED BASEG4
Size 44544
Digest type shal
Digest +¥FzM3Ps X 3PNWDE+BVZCs784fGE=
Detatched digest +YfzM3Ps{3PNwWDE+BVZCs784fGE=
File charset 150-8859-1 =
Pok |
= =]

The signature info dialog has two panels displaying signature and OCSP
confirmation details.

Signature Info %

ANSIP.ANDRUS, 35610012722
Signature Notary |

Item E‘u’alue
ldl 50
Timestamp 2002.10.07 15:10:19
= Signature production place
Tallinn
Eesti
Signature type RSA
Issuer serial 1033646604
Certificate digest +WdXfe 7NObuhgqBEEHS|ZoMWXg
4 b

Kz




9
ANSIP.ANDRUS, 35610012722
'S.i.gnature MNotary
ltern WValue
id ND
Produced at 2002.10.07 14:10:47
Motary type OC5P-1.0
Responder id JC=EE/O=ESTEID/OU=0CS5P/CN=ESTEID-5K OCSP
Issuer serial 1033646604
QCSP Monce +z]k5eEWrlO5QozRWTBXx OHEXGWE=
Certificate digest yi+f5CofZp)ssWcth/dxIVCwxwc=
QOCSP digest XOQVSVCOMLOZcg3YKdeQpmngPRac=
KTl D
9o

= =
The menuitem Help -> Info opens the “About gdigidoc” dialogbox that displays
copyright a1_1d other info.

GDigiDoc Info

-

Copyright (C) 2003 by Veiko Sinivee
veiko.sinivee@solo.delfi.ee

!l:i

[EE X ) o

-3 GDigiDoc 0.0.5
ll';'l“

RN

O |
e =i

This dialog has four panels. The second panel displays information about the
libdigidoc version used, supported file formats and configuration file settings.



GDigiDoc Info

Itern

Value

Library Digi Doc Lib

Version 1.88
=~ Supported Formats
SK-XML 1.0
DIGIDOC-XML 1.1
DIGIDOC-XML 1.2
DIGIDOC-XML 1.3
Default driver OpensC

Default format
Responder URL
HTTP proxy

DIGIDOC-XML - 1.3
http:/focsp.sk.ee
proxy.sebank.se - 8080

On the third panel we see the reistered CA and responder certificates.

GDigiDoc Info 5

IGDu_i:DﬂEED@DE Certs E[.'lﬁuers |
Certificate |File
T CA Certificates

Juur-5K

fusrflocal/share/certs/JUUR-SK.PEM.cer

ESTEID-5K fusrilocal/share/certs/ESTEID-SK.PEM.cer
TEST-5K fusrflocal/share/certs/TEST-SK.PEM.cer
KLASS3-SK fusrflocal/share/certs/KLASS3-5K.PEM.cer

=~ Responder Certificates
ESTEID-5K OCSP RESPONDER fusr/local/share/certs/ESTEID-S5K OCSP RESF“Ol
TEST-5K OCSP RESPONDER fusrflocal/share/certs/TEST-5K OCSP RESPONL
KLASS3-SK OCSP RESPONDER fusrflocal/share/certs/KLASS3-5K OSCP RESPC!




On the last panel we see a list of the registered PKCS#11 drivers.
GDigiDoc Info

G.D.i.giﬁuc :ﬁigiDuc | Certs Drivers

Name iDe&criptiDn

~ 3 EYP driver Eesti Yhispanga loodud ID kaardi PKCS#11 ohjurprogramm
¥ OpenSC  OpenSC baasil loodud PKCS#11 ohjurprogramm

o

Here we see the driver provided by OpenSC library and another driver develeoped
by Eesti Uhispank. If you right-click on one of the drivers in the list and select
“Driver Info” the a dislogbox will appear and display a list of cardreaders and slots

found using this driver. This is a good way to test if the program can access the
smartcard.

(owErEe ®

Item |Description
Opensc OpenSC baasil loodud PKCS#11 ohj
File fusrflocalflib/pkcs11/opensc-pkcsl
Cryptoki Version 2.11
Manufacturer OpenSC Project (www.opensc.org)
Library Version 0.08
Library description SmartCard PKCS#11 API

- @ OpensSC project (www.opensc.org) OMNIKEY Cardman 4000 Socket 0 0
Hardware Version 0.00
Firmware Version 0.00

I EstEID isikutunnistus (PIN1 - Au

o @ OpenSC project (www.opensc.org) OMNIKEY Cardman 4000 Socket 0 0
Hardware Version 0.00
Firmware Version 0.00

= EstEID isikutunnistus (PINZ - Al
Manufacturer AS Sertifitseerimiskeskus
Mode| PKCS #15 SCard
Serial Nr A0011893
Has random generator NO
Write protected NO ) E:
4 3|

KT
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