
KDE Quick Start
openSUSE 11.3

openSUSE® provides the tools that Linux* users require in their daily activities. It comes with an easy-to-use
graphical environment (KDE* desktop) that communicates with the underlying Linux system to access and
manage files, folders, and programs. openSUSE provides an integrated suite of applications for a wide range of
purposes (office, multimedia, Internet). The OpenOffice.org suite is also included, which allows you to edit and
save files in a number of formats. Because the office suite is available for several operating systems, you can
use the same data across different computing platforms.

Getting Started
When you start your system, you are usually prompted to
enter your username and password. If you did not install
the system yourself, check with the system administrator
for your username and password.

After logging in to KDE for the first time, you see the KDE
desktop, which shows the following basic elements:

Desktop Folder: By default, the desktop folder shows
the contents of its ~/Desktop directory. Whenever you
insert a file into this directory, it appears in this view too.

Desktop Context Menu: Right-click an empty area on
the desktop to access the context menu for configuring the
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appearance of the desktop, adding panels or widgets to the
desktop, configuring desktop settings, locking the widgets
in their current position, leaving the current session, or for
locking the screen.

Desktop Toolbox: Move your mouse pointer to the icon
in the upper right corner of the desktop to access the menu
that lets you add or lock widgets.

KDE Panel: By default, the panel of your KDE desktop
consists of theMain Menu icon on the left, further widgets
and program icons, and the panel settings icon on the right.
If you hover the mouse pointer over an icon in the panel,
a short description is displayed.

Modifying Desktop Panels
The bottom panel can be customized to suit your individual
needs, and additional panels can be configured to further
personalize your desktop. Customize it with a right-click on
a blank space in the panel and select Panel Options →
Panel Settings. An additional area above the panel opens.
This let you add additional widgets and spacers, lock wid-
gets, or get more settings.

Adding and Removing Panels
To add a new panel, right-click an empty area on the
desktop and select Panel Options → Add Panel. To delete
a panel, right-click a blank space in the panel you want to
delete and select Panel Options → Remove this Panel.
openSUSE requires that at least one panel is left on the
desktop.

To add new widget, proceed with Section “Adding and Re-
moving Widgets”.

Adding and Removing Widgets
Widgets are small applications that can be integrated into
your panel:

1. To add a widget to the panel, right-click an empty patch
on the panel, and select Panel Options→ AddWidgets.

If these menu items are not available, your desktop el-
ements are probably locked. Unlock them first as de-
scribed in Section “Locking and Unlocking Desktop
Objects”.

2. In the dialog box that appears, you can limit the selec-
tion of widgets that is shown with the drop-down list
at the top.

3. Select a widget and click Add Widget. The widget ap-
pears in your panel.

Starting Programs
Start programs from theMainMenu or from the command
line, using a shell or the Run Command. Additionally, you
can start programs from the desktop or the panel by left-
clicking the program icon once.

Using the Main Menu
To open the Main Menu, click the Main Menu icon in the
panel or press Alt + F1. The Main Menu consists of the fol-
lowing elements: a search function at the top and several
tabs at the bottom, providing quick access to the key
functions of the menu. Additionally, the menu displays your
login name and the hostname of your computer.

Favorites shows a default selection of key programs for
quick access, whereas Applications shows all applications
installed on your system. To navigate through the menu
structure, click an entry and use the arrow icons at the right
or the left to switch back and forth. Computer and Recently
Used provide quick access to some frequently used places,
applications, or documents. Leave shows several options
for leaving the session such as logging out, locking the
screen (access can only be regained with a password),
shutting down or restarting the computer. Some computers
offer to suspend your session to RAM or disc.

If you often need a program and do not want to dig into
the menu structure, you can integrate it into the favorites
tab. Right-click on your icon and choose Add to Favorites.

Using the Run Command Dialog
KRunner is a helper application that lets you quickly start
programs. Apart from that, it offers a search function for
finding applications or locations.

Press Alt + F2 to open the Run Command dialog. Type a
command, for example, dolphin, and press Enter or click
Launch to start the application. The command to start the
application is often (but not always) the application name
written in lowercase.
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The Run Command dialog allows you also to use different
features. Click on the question mark icon to see a list of
active features. To configure or get a list of all features,
click on the wrench icon. You can use so-called Web short-
cuts defined in Konqueror to send search requests directly
to a search engine without first opening the browser. An-
other interesting feature is to calculate a mathematical ex-
pression like =2+2^4-sin(2). Very useful is to convert
units, for example, from miles per hour into kilometres per
hour. Just insert the expression 60 mph in km/h to get
the converted value.

Searching for Programs
Both the Main Menu and the Run Command dialog offer a
search function that lets you quickly start programs even
if you do not already know the exact application name or
command. To search for an application, start typing a
command or part of the application name in theMainMenu
Search field or the input field in the Run Command dialog.
Each character you enter narrows down the search.

From the list below the input field, choose the application
matching your query.

Handling Media
If you insert a CD or DVD into your drive or plug in a
pluggable device (for example, a USB stick or removable
hard disk), the device notifier widget opens a small note
alerting you to this. Click on the pluggable device to show
the available actions. Usually you can open its content in a
file manager. Depending on the device, several other actions
are possible. For example, if you plug in a digital camera,
the actions allows you to download your photos with
Gwenview or Digikam.

Customizing Your Desktop
You can change the way your KDE desktop looks and be-
haves to suit your personal preferences.

Locking and Unlocking Desktop Objects
Desktop elements can be locked in their current position
to prevent them from being moved around on the desktop.
As long as the desktop elements are locked you cannot add,
move, or remove any objects to or from your desktop.

To lock or unlock the desktop elements, click the desktop
toolbox at the upper right corner of the desktop and select
Lock Widgets or Unlock Widgets.

Conversely, right-click an empty patch on the desktop and
select menu items from the context menu.

Changing Individual Desktop Elements
In the following, you can find some examples of how to
change individual desktops elements.

Adding Program Icons to the Desktop
To create a link to an application and place it on the desk-
top or the panel, proceed as follows:

1. Click theMain Menu button and browse to the desired
application.

2. Right-click and select Add to Desktop from the context
menu that appears. If these menu items are not avail-
able, your desktop elements are probably locked. Un-
lock them first as described in Section “Locking and
Unlocking Desktop Objects”.

3. To change the icon position on the desktop, left-click
the icon and drag it to the desired position.

To delete an icon from your desktop, right-click the pro-
gram icon and select Remove this Icon.

Adding Widgets to the Desktop
Desktop widgets (or “plasmoids”) are small applications
that can be integrated into your desktop or panel. To add
widgets to you desktop, proceed as follows:

1. Right-click an empty patch on your desktop and select
Add Widgets.

If these menu items are not available, your desktop el-
ements are probably locked. Unlock them first, as de-
scribed in Section “Locking and Unlocking Desktop
Objects”.

2. In the dialog box that appears, limit the selection of
widgets that is shown with the drop-down list at the
top.
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3. Select a widget and click Add Widget. The widget ap-
pears on your desktop.

4. To position the widget on your desktop, left-click the
widget and drag it to the desired position.

To remove a widget from your desktop, right-click the
widget and select the Remove... entry.

Configuring Widgets
In order to configure widgets, the desktop elements need
to be unlocked as described in Section “Locking and Unlock-
ing Desktop Objects”. To configure a widget, proceed as
follows:

1. Hover your mouse pointer over the widget until a
translucent frame appears around the widget, showing
a number of symbols.

If the frame does not appear, your widgets are probably
locked. Unlock them first as described in Section
“Locking and Unlocking Desktop Objects”

2. To change the widget size, left-click the scale symbol
in the frame and keep the mouse button pressed while
slowly moving your cursor across the desktop to scale
the widget size.

3. To rotate the widget in any direction, left-click the ar-
row symbol in the frame and keep the mouse button
pressed while moving your cursor in a circle across the
desktop. There is a sticky boundary in the horizontal
and vertical positions where you can “clamp” the widget,
if you like. Of course, you can also arrange it in any
tilted position.

4. To change the contents, settings, or properties of a
widget, left-click the wrench symbol in the frame. De-
pending on the widget, there could be nothing to con-
figure. In the configuration dialog box that appears, set
the options according to your wishes.

5. Use the X symbol in the frame if you want to close the
widget.

You can customize the KDE Panel according to your prefer-
ences: Applications and widgets can be added to the quick
launch area or the system tray in the main panel, or in ad-
ditional panels. Panel elements and additional panels can
be moved to different places or be completely removed at
any time.

• Click on the desktop toolbox (lower right corner, half-
round icon) to open the settings panel. If you cannot find
the desktop toolbox, it is probably locked. Right-click on
a widget and choose Unlock Widgets.

• To move a panel object to a different place within the
panel, hover the mouse over the relevant widget. The
mouse cursor turns into a crosslines-like form. When you
click on the widget, you can move it to a different posi-
tion. Click again to fix it at this place.

• To change the overall appearance or behavior of the
panel, click on the icons at the borders of the settings
panel. The icons have the form of arrows and you can
change the adjustment of the left and right side. If you
click on one of these icons and drag them inside, the
width of the panel is immediately changed.

The icons in the settings panel have the following meaning:

• To place the panel on different sides of the screen use
the Screen Edge button. Drag and drop it to the preferred
place.

• To change the height of the panel, click the Height button
and move the mouse cursor to the end location.

• If you need additional widgets on your panel, place them
with the Add Widgets... button.

• To enlarge the distance between two widgets, use Add
Spacer.... A spacer widget appears on the right side. Drag
and drop it to your preferred place.

• To prevent the panel and widgets from being moved ac-
cidentally, use Lock Widgets.

• To adjust additional configurations, use More Settings....
• Close the settings panel with the red close button on the
right side.

Changing the Desktop Background
You can change the background of your desktop to display
colors, patterns, images and more. To select a picture to
use as the background, proceed as follows:

1. Right-click an empty patch of the desktop and select
Desktop Settings. A configuration dialog appears.

2. From the Wallpaper label use the Type drop-down list,
choose Image or Slide Show as the background.

• For an image wallpaper, choose a default wallpaper
from the Picture list. Download and install new wall-
papers with Get New Wallpaper.... To use a custom
picture, click the folder button beneath the list and
select an image file from the file system. Define the
Positioning of the image.
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• To have multiple images appear in Slide Show mode,
define the directory from which to select the pictures
and set the time interval for the image change.

• If you do not want an image or slide show, you can
set a Color as desktop background.

3. Set the other options in the configuration dialog accord-
ing to your wishes, and click OK to save your changes
and leave the configuration dialog.

Modifying Personal Settings
Apart from changing individual desktop elements, KDE al-
lows you to personalize your desktop to a very high degree.
Possibilities to adjust the overall appearance and behavior
of your desktop can be found in the Personal Settings
configuration dialog.

Start the Personal Settings from theMainMenu by selecting
Favorites → Configure Desktop.

The General and Advanced tabs provide different categories
of settings. To get an impression of the numerous possibil-
ities, just hover the mouse over the category icon to display
a list of its content. Performing tasks in some areas of the
control center requires system administrator (root) permis-
sions.

If you do not like the view style, click on the Configure
button to change it to a classical tree view.

Change the settings as desired. No changes take effect until
you click Apply. To discard changes in the recent view that
you have not yet applied, click Reset. To reset all items in
the recent view to the default values, click Defaults.

To get back to the start-up view showing all categories
again, click Overview. You can also enter a search string at
the top of the window (for example, Screen Saver) to find
the category which holds options related to the search
string. Each character you enter in the Search field narrows
down the search.

Applying Desktop Effects
If your computer supports a 3D graphics card with Xgl, you
can use graphical effects like turning your desktop into a
rotating 3D cube, enabling translucent or transparent win-
dows, and zooming in and out of the desktop screen. You
can also use other window effects such as shadows, fading,
and transformations. If you do not have a 3D graphics card,
some effects may be disabled or reduce the performance
of your system. If the performance of your system is too
low, disable the compositing effect for your current session
with Alt + Shift + F12.

To configure the effects on your desktop, proceed as fol-
lows:

1. Start the personal settings window as described in Sec-
tion “Modifying Personal Settings”.

2. Select Desktop → Desktop Effects and choose Enable
Desktop Effects. If your graphic card does not support
3D, you will be notified.

3. Optionally, choose some configuration from Common
Settings

4. Select the effects in the All Effects tab. The info icon
gives you a small explanation. Some effects may have
a configuration dialog for further adjustments.

5. Use Apply to enable the effects permanently.

With Xgl , you can make use of the following effects:

• Wrap your virtual desktops around a cube and rotate the
cube to get to another virtual desktop. Rotate the cube
with Ctrl + Alt + → or Ctrl + Alt + ←.

• Fly through the range of virtual desktops without having
to use the pager and select the one to use. To change to
this panel-like view, use Ctrl + Alt + ↓. To scroll to a
desktop left or right of the current one, keep holding
Ctrl + Alt and use → and ←.

• Zoom into certain parts of the desktop. Select the area
to enlarge and right-click while holding the Windows key.

• Show all windows opened on one virtual desktop as if
they were resized so all fit in the display at once. Arrange
the windows using Ctrl + Alt + ↑. While holding down
Ctrl + Alt, use the arrow keys to determine the focus.

Using Virtual Desktops
The desktop environment allows you to organize your pro-
grams and tasks on several virtual desktops. If you often
run a lot of programs simultaneously, this minimizes the
number of windows to arrange on your screen. You might,
for example, use one desktop for e-mailing and calendaring
and another for word processing and graphics applications.

Moving an Application to Another Virtual Desktop
You can display a running application on one or all virtual
desktops, or move it to other desktops.
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1. Open the application.
2. Right-click the title bar of the application.
3. Click To Desktop.
4. Select the desktop on which to place the application.
5. To switch between desktops, click the desired desktop

in the pager in the panel.

Adding Additional Virtual Desktops
Some users might need more desktops than are provided
by default. To add additional desktops:

1. Right-click the pager in the panel and select Configure
Desktops. A configuration dialog appears where you
can increase or reduce the number of virtual desktops.
You can also change the default names of the desktop.

2. Click OK to apply the changes and to close the configu-
ration dialog.

3. If you want the names of the desktops to appear in the
pager rather than the number, right-click the pager and
select Pager Settings.

4. From the radio button list, select Desktop Name and
click OK to apply your changes and close the dialog.

Using the File Manager
With KDE 4, Dolphin has replaced Konqueror as the default
file manager. Konqueror remains a Web browser (refer to
Section “Browsing the Internet”). To start Dolphin, click the
card box icon in the panel or press Alt + F2 and enter
dolphin.

Dolphin Main Window
The Dolphin main window consists of the following ele-
ments:

Menu Bar: The menu bar holds menu items for actions
like copying, moving, or deleting files, changing views,
starting additional tools, defining your settings, and getting
help.

Toolbar: The toolbar provides quick access to frequently
used functions that can also be accessed via the menu. If
you hover the mouse pointer over an icon, a short descrip-
tion is displayed.

Location Bar: The location bar displays the path to the
current directory. It is available in two versions: one shows
the path to the current directory with icons for every parent
folder in a “bread crumb” view. Click any icon in the bread
crumb view to change to that directory. The second version
of the location bar shows the path to the current directory
as a string of text you can edit.

Panels: By default, Dolphin shows only the Places panel
on the right. It allows quick access to some often-used
places like your home directory, the root directory of the
file system (/), the trash bin, and removable media. There
are several other panels you can add to the main window.

Display Field (Working Space): The display field shows
the contents of the selected directory or file. By default,
Dolphin displays the contents of your home directory on
start-up. Clicking a folder or file in Dolphin directly starts
an action: Dolphin loads the file into an application for
further processing or opens the folder.

Status Bar: Shows the file type and size of the currently
selected object and the available disk space .

Managing Files and Folders with Dolphin
To perform actions like copying, moving, creating or delet-
ing files, you need appropriate permissions to the folders
and files involved in your action.

To copy, move, or delete a file or folder, proceed as follows:

1. In order to select one or multiple files and folders in
Dolphin, move your mouse over the icon but do not
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click. A green cross appears on the upper-left edge. If
you click on it, the icon is selected. You can also press
Ctrl and click the file or files.

2. Right-click and select Copy or Cut from the context
menu.

3. Navigate to the destination folder in which to insert the
object.

4. To create a new folder at the current location, select
File→ Create New→ Folder or press F10. Enter a folder
name in the new window and press Enter.

5. To insert the object you copied or cut in Step 2, right-
click the destination folder in the main display field and
select Paste. The object is copied or moved there.

6. To delete a file or folder, right-click the object in the
main display field and select Move to Trash from the
context menu. The object is moved to the trash bin.
From there, you can restore it if necessary or delete
the object permanently.

To quickly filter for certain filenames in the current directo-
ry, press Ctrl + I to add the Filter input field to the bottom
of the Dolphin main window. Type any part of the filename
you are searching for to see all files in the current directory
containing the search string. For more detailed and ad-
vanced searches, press Ctrl + F to use KFind. For more in-
formation, refer to Section “Using KFind”.

Configuring Dolphin
Dolphin offers many options for adjusting the view and the
overall settings according to your preferences.

Changing the View
1. To switch from the bread crumb view to the editable

version of the location bar, press F6. Enter a path to a
directory by typing it in. After typing an address, press
Enter or click on the background of the bread crumb
view.

To delete the contents of the location bar click the
black X symbol on the left. To switch back to bread
crumb view, press Ctrl + L.

2. To change the view of the currently displayed folder,
either click Icons, Details, or Columns in the toolbar.
Dolphin remembers the selected view for each folder.
Click Split or press F3 to view the contents of the cur-
rent folder in two separate columns. Now you can
navigate to a different directory in each column and
easily drag or drop objects or compare the contents of
directories.

3. To make Dolphin also show hidden files, select View→
Show Hidden Files or press Alt + +.

4. To view more details about the files (like access permis-
sions or ownership) in the working space, select View
→ Additional Information and enable the corresponding
options.

5. To add further directories to the Places panel, drag a
folder from the working space to the Places panel and
drop it there. Right-click and use the context menu to
hide, edit or remove entries from Places.

6. To add more panels to the main window, select View
→ Panels and select additional panels such as Informa-
tion, Folders, or Terminal.

• The Information panel shows the properties and a
preview of the currently selected file. It also lets you
add comments to the file.

• The Folder panel shows a tree view of the whole file
system and lets you navigate trough all subdirectories
of /root.

• The Terminal panel attaches a command line to the
bottom of the main Dolphin window. Whenever you
click a certain directory in the display field, the Ter-
minal panel also changes to that directory, so you
can easily switch to the command line for certain
tasks you prefer to execute in a shell.

Detach the panels from the main Dolphin window by
clicking the left icon at the top of each panel. Click the
panel's title bar and drag it to another place on the desktop.
To reintegrate the panel into the Dolphin window, click the
left symbol at the top of the panel again.

If you want to change Dolphin's overall behavior or view,
select Settings→ Configure Dolphin and explore the options
offered in the Dolphin configuration dialog.

1. To use the same view mode for all folders, click View
Modes in the left sidebar. Activate Use Common View
Properties for All Folders on the General tab. Adjust the
options for the individual view modes on the other tabs
and click Apply to save the changes.

2. If you want Dolphin to show a different directory on
start-up, or if you want to permanently use the editable
location bar instead of the bread crumb view, change
the relevant options on the General tab.
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3. Click OK to save the changes and to close the Dolphin
configuration dialog.

Browsing the Internet
Apart from Konqueror (KDE's default Web browser),
openSUSE also includes the default Firefox Web browser.
To start Konqueror or Firefox, press Alt + F2 and enter
konqueror or firefox.

With features like tabbed browsing, pop-up window block-
ing, and download and image management, both browsers
combine the latest Web technologies. Their easy access to
different search engines helps you find the information you
need.

Enter a URL in the location bar to start browsing. To open
a new, empty tab, press Ctrl + T. To open a link in a new
tab, click the link with your middle mouse button. Right-
click the tab itself to access more tab options. You can
create a new tab, reload one or all existing tabs, or close
them. You can also change the sequence of the tabs by
dragging and dropping them to the desired position.

Finding Information
Both browsers offer different kinds of search options: you
can find information on the Web or you can search the
current Web page for keywords.

Searching the Web
1. To start a search on the Web, click the left icon in the

search bar on the right to open a list of search engines.
2. Select the desired engine and type your search keywords

into the input field.
3. Press Enter to start the search.

Searching the Current Web Page
1. To search the current Web page for keywords with

Konqueror, press Ctrl + F, opening the Find dialog. Type
your search keyword and press Enter.

2. To search the current Web page with Firefox, press Ctrl
+ F to open a find bar at the bottom of the window.

Enter your search keyword there and use the buttons
beneath the bar to search in different directions or to
highlight all hits in the text.

Konqueror offers Web shortcuts for quickly searching the
Web. For example, to search the Web for yast using the
Google search engine, just type gg:yast into the Kon-
queror location bar (or the Run Command dialog) and press
Enter.

Apart from predefined shortcuts such as gg for Google or
wp for Wikipedia, you can also define further, individual
Web shortcuts as described in Section “Configuring Prefer-
ences”.

Downloading Files from the Web
If you download a file with Firefox or Konqueror, a dialog
window appears asking you if you want to save the file. In
Konqueror, you then need to specify the location for the
file. By default, Firefox saves the file to the folder configured
in the Firefox Preferences and shows your finished downloads
in the Downloads dialog.

To open the downloaded files directly from there, right-
click and select Open. To clean up the history of download-
ed files, right-click and select Clear List.

Configuring Preferences
Adjust preferences in Konqueror or Firefox. In Konqueror,
access the configuration dialog with Settings → Configure
Konqueror. To change the behavior of Konqueror as Web
browser, select one of the Web Browsing categories in the
left sidebar to show the options for the relevant category.
For example, you can “hide” Konqueror's real identity and
make Konqueror identify as a different browser (for exam-
ple, Internet Explorer*) for certain Web sites you visit. To
do so, select Browser Identification, and click New to add a
new, site-specific identification.
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You might also want to configure the Web shortcuts you
can use with Konqueror (and the Run Command dialog).
In the Konqueror configuration dialog, clickWeb Shortcuts
to see which shortcuts are already defined. Click New to
define new shortcuts. Leave the Konqueror configuration
dialog with OK to apply your changes.

In Firefox, select Edit → Preferences to open the Firefox
Preferences. Click the icons in the upper display field to ac-
cess the options for the relevant category. For example,
change the default download folder on the Main page, or
adjust the pop-up blocking feature on the Content page.
Click Close to apply the changes.

Managing Passwords
When you enter a password in a KDE application for the
first time (in KMail or Konqueror, for example), you are
asked if you want to store the password in an encrypted
wallet. If you click Yes, KWallet wizard starts by default.
KWallet is a password management tool that can collect all
passwords and store them in an encrypted file.

To activate KWallet, select Basic Setup and click Next. Select
Yes, I wish to use the KDE wallet to store my personal infor-
mation and enter a password. This is your master password
to open KWallet.

Protect Your KWallet Password
If you forget your KWallet password, it cannot be
recovered. Furthermore, anyone who knows your
password can obtain all information contained in
the wallet.

Click Finish to close the wizard. After this initial configura-
tion, you can open your wallet at any time to view, search,
delete, or create entries. Normally you do not need to insert
an entry manually. KDE recognizes if a resource requires
authentication and KWallet starts automatically, prompting
you for the KWallet password. However, you can add addi-
tional data if you wish.

Whereas KWallet is designed to centrally manage passwords
for several KDE applications, Firefox also offers the ability
to store data when you enter a username and a password
on a Web site. If you accept by clicking Remember, the
password will be stored on your hard disk in an encrypted
format. The next time you access this site, Firefox will auto-
matically populate the login fields.

To review or manage your passwords in Firefox, click Edit
→ Preferences → Security → Saved Passwords....

E-Mailing and Calendaring
For reading and managing your mails and appointments,
you can use Kontact as your personal information manage-
ment tool (PIM). Kontact combines KDE applications like
KMail, KOrganizer, and KAddressBook into a single interface.
This gives you easy access to your e-mail, calendar, address
book, and other PIM functionality. Kontact can also manage
multiple e-mail accounts.

Starting Kontact for the First Time
To start Kontact, press Alt + F2 and enter kontact. To
access one of the components, click the corresponding icon
in the left sidebar.

Before you can send or receive mails, you must configure
an e-mail account. Create first a new identity with the re-
spective name and email address (choose from the menu
Settings→ Configure KMail... and go to Identities). To create
an account, switch to the Accounts icon in the same dialog
box and create your incoming and outgoing mail. Finish
with Ok.

If you want to modify your e-mail account (for example, if
you need to change any ports or want to add a second ac-
count), click theMail icon, then select Settings→ Configure
KMail to open the configuration dialog. If you are not sure
about the settings or items to select, consult your Internet
Service Provider or system administrator.

To write a new mail, click theMail icon in the Kontact main
window and press Ctrl + N to open the mail composer. After
you have finished your mail, click Send to send it immedi-
ately. In case you have configured multiple e-mail accounts,
keep the Send button pressed, then select the account from
which you want to send the mail.

Instant Messaging with Kopete
Kopete is an online messenger application that allows mul-
tiple partners connected to the Internet to chat with each
other. Kopete currently supports a number of common
messenger protocols, such as AOL* Instant Messenger (AIM),
Gadu-Gadu, GroupWise® Messenger, ICQ, Jabber*, MSN,
SMS, and Yahoo!*. To be able to use instant messaging (IM),
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you must register with a provider offering IM services and
configure a Kopete account.

To start Kopete, press Alt + F2 and enter kopete.

To configure an account, proceed as follows:

1. Select Settings → Configure.
2. Choose Accounts and click Add Account.
3. Select your messaging service.
4. Enter your account information. If the messaging service

requires registration but you do not have an account
for this service yet, proceed as follows:

a. Click Register NewAccount. In the browser window
that opens, enter your user data to register.

b. Switch back to Kopete and enter the data received
on registration with the messaging service. This
usually consists of the nickname or e-mail address
and a password. Complete the configuration of
your account by clicking Finish.

5. Create a new identity with Add Identity.... Usually this
is not really necessary, but sometimes you want to dis-
tinguish between private and business contacts. A new
identity helps to separate these two areas. In the dialog
box that opens, enter your nickname and e-mail ad-
dress. Close with Ok.

6. Drag and drop your account to the newly created
identity. It is now listed under the identity.

7. Finish with Ok.

If you decided to go online after configuring your account,
you can now add contacts in the main Kopete window.
Otherwise, first click File → Set Status → Online and enter
your password if you are prompted for it. After connecting,
click File→ Add Contact and select the Kopete account for
which you want to add contacts. Enter the contact data or
search for a contact and click OK.

To view all your contacts, even if they are offline at the
moment, select Settings → Show Offline Users.

To start a chat with someone, click the desired contact and
type your message in the lower part of the chatting window.
Press Enter to send the message. The upper part of the
window displays the messages you have sent and received.

Starting OpenOffice.org
The office suite OpenOffice.org offers a complete set of
office tools, including word processor, spreadsheet, presen-
tation, vector drawing, and database components. Because
OpenOffice.org is available for a number of operating sys-
tems, you can use the same data across different computing
platforms.

To start OpenOffice.org in the word processor view, press
Alt + F2 and enter oowriter. Conversely, start OpenOf-
fice.org Writer from the Main Menu. To create a new doc-
ument, select File→ New and choose the type of document
to create. To open an existing document, select Open and
choose the appropriate file from the file system.

Viewing PDF Files and Other
Documents
Documents that need to be shared or printed across multi-
ple platforms can be saved as PDF (Portable Document
Format) files, for example, in the OpenOffice.org suite. View
them with Okular, the default KDE document viewer.

Using Okular Document Viewer
Apart from PDF files, Okular allows you to view a great
number of file formats, such as PostScript, several image
formats, OpenDocument format (ODF), OpenDocument
text (ODT), some eBook formats (ePub), and even Micro-
soft* Compiled HTML Help (CHM). Okular also provides
support for bookmarks, annotations, form fields and multi-
media content, and the rotation of pages.

Start Okular from the Main Menu or press Alt + F2 and
enter okular.

To open a document, select File → Open and choose the
desired file from the file system. Navigate through the
document by using the navigation icons at the top or bot-
tom of the window. Depending on which icon you click on
the navigation panel on the left, the sidebar either shows
a table of Contents, a Thumbnail view of each page, the
Reviews for this file, or your Bookmarks for this file. To filter
for any text listed in the sidebar or the overall document,
enter a string into the input field at the top of the sidebar.
If you want to select and copy text or images from the file
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in Okular, click the Selection icon in the toolbar and select
one of the options from the context menu. Click the Browse
icon to switch back to browsing the document.

Working with Bookmarks and Annotations
With Okular, you can review a document by highlighting
certain text parts or adding annotations or bookmarks that
Okular then attaches to the file in the form of metadata.
Note that the annotations and markers you add are not
stored within the document, so you cannot print them or
pass them on to other users.

1. To add a bookmark for a page, click the page in the
sidebar or in the main display field and press Ctrl + B.
The page is added to the Bookmarks list on the left
sidebar. Right-click the bookmark entry to access a
context menu for going to this bookmark or renaming,
or removing it.

2. To create an annotation for a page, press F6 and select
one of the annotation tools from the toolbar that ap-
pears. The annotation is added to the list of Reviews
and is flagged with the login name of the user who
created it. Use the icons at the bottom of the sidebar
to group the annotations by page, by author or to show
the annotations for the current page only.

3. To open a pop-up note and add text for an annotation
(or to remove an annotation), right-click the annotation
entry in the Reviews list and select the corresponding
menu item. The annotations or markers you added are
automatically attached to the file, you do not need to
save them.

Using Acrobat Reader
Acrobat Reader is not installed by default, install the
acroread package with YaST. To start Acrobat reader,
press Alt + F2 and enter acroread or start the program
from theMain Menu. Click File→ Open, locate the desired
PDF file and click Open to view the file.

Searching for Data
KDE provides more than one application for finding data
on your computer or in the file system. One application is
KFind, which is described below.

Using KFind
To perform basic and advanced searches, use KFind. Start
it from the Main Menu by clicking Applications → Find
Files/Folders or press Alt + F2 and enter kfind.

Searching by Name
To use a filename (or a part of it) as the search keyword,
proceed as follows:

1. Enter the filename or a part of the filename in the
Named input field. Use wild cards, such as an asterisk
(*), to indicate missing characters in the filename.

2. Specify the folder in which to search for the file. Either
enter a path to the folder in Look in or click Browse to
locate the folder.

3. To search subfolders, check Include Subfolders.
4. Click Find to start the search. The results are displayed

in the lower part of the dialog. To directly open the
result, just click it. Right-click it to choose one of the
options from the context menu.

Searching by Contents or Properties
For a more detailed search, you can also specify further
options, such as a text the file must contain or the creation
or modification date of a file. To search for content or
properties, proceed as follows:

1. On the Name/Location tab, specify at least the path to
search for the file. You can leave Named empty.

2. To search for certain content in a file, click the Contents
tab. In Containing Text, enter the word or phrase the
file to find must contain. This option does not work for
all types of files.

3. To search for properties such as creation or modifica-
tion date of the file, click the Properties tab and choose
the options you want.

4. Click Find to start the search.
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Creating a CD or DVD
If you possess a CD or DVD writer, you can burn files to a
CD or DVD with K3b. To create a data CD or DVD, proceed
as follows:

1. Press Alt + F2 and enter k3b. K3b opens.
2. Select File → New Project → New Data Project from

the main menu.
3. Use the tree view in the top left part of the window to

search for the files or folders to burn. When they appear
in the top right part of the window, drag and drop them
into the Current Projects window.

4. Change the name of your medium in the VolumeName
textfield.

5. Insert a writable CD into the device then click the Burn
icon.

6. Check the settings in theWriting tab. Usually this should
work well for almost all files. If you wish, you can
change more information in the Filesystem tab. files.

7. Click Burn.

Managing Your Digital Image
Collection
With digiKam, it is easy to manage your digital images:
download your images from the camera, edit and improve
them, organize them in albums (or flag them with tags for
easy retrieval, independent of folders or albums), and
archive them on CD, or export them to a Web image gallery.

digiKam also contains a set of useful batch functions and
plug-ins, allowing you to convert multiple images to various
different formats, rename multiple images, or automatically
improve them with functions such as red eye reduction,
speck removal, and hot pixel removal. Various filter and
effects plug-ins help create works of art from your digital
images.

To start digiKam, press Alt + F2 and enter digikam. On
initial start-up, the first-run wizard appears. It asks the loca-

tion where to store your images and metadata. Usually you
can accept the default paths.

digiKam's main window contains a tree view on the left and
shows thumbnails of the images on the right. For quick ac-
cess to your images, use the sidebar on the left, which allows
you to switch between different views, sorting the images
according to Albums, Dates, Tags or Searches. To enter
digiKam's viewing and editing mode, double-click an image
thumbnail.

Managing Your Music Collection
KDE's Amarok music player allows you to play various audio
formats, create playlists, listen to streaming audio broadcasts
of radio stations on the Internet and subscribe to podcasts.
The file types supported depend on the engine used for
Amarok.

To start Amarok, press Alt + F2 and enter amarok.

Amarok's main window shows a sidebar on the left providing
different views: your music collection, some addresses to
listen to podcasts or streams from the Internet, your playlists
and a file browser. The middle part, the context browser,
displays information about the current track, the Wikipedia
page of the artist and the song's lyrics by default. The right
part of the window shows the current playlist. To play music,
just drag and drop items from any of the sidebar browsers
to the playlist area. Double-click an item in the playlist to
start playback.

If your music files are properly tagged (containing at least
information about the artist and album), you can make use
of several nice Amarok features. To automatically retrieve
the album cover images from Amazon, select Tools →
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Cover Manager and click Fetch Missing Covers. The next
time you play a track from this album, the cover is displayed
in the context browser and on the on-screen display. To
learn more about the artist, click on the Wikipedia button
in the middle area to make Amarok search for the appro-
priate Wikipedia article.

To configure the use of another engine (or various other
Amarok features), select Settings → Configure Amarok.

Logging Out
Log out (and leave the system running), restart or shut down
the computer.

Logging Out or Switching Users
Click theMainMenu button on your panel and select Leave
→ Logout. This ends your session but leaves the system
running. To start a parallel session as a different user, select
Leave → Switch User instead.

Restarting or Shutting Down the Computer
Click Leave, then select one of the following options:

Shutdown
Logs you out of the current session, then turns off the
computer.

Suspend to RAM
Pauses your current session without logging out. Your
computer consumes very little power, but can be brought
back to fully-functional status very quickly.

Suspend to Disk
Suspends your session, using no power until the comput-
er is restarted. The state of your session is preserved,
however, including all applications you have running and
all documents you have open.

Restart
Restarts your computer.

For More Information
This guide gave you a short introduction to the KDE desktop
and some key applications running on it.

Find the other manuals available for openSUSE at http://
www.novell.com/documentation/opensuse113 or
in your installed system under /usr/share/doc/manual.

To learn more about KDE and KDE applications, also refer
to http://www.kde.org/ and http://www.kde-apps
.org/.

Legal Notice
Copyright© 2006–2010 Novell, Inc. and contributors. All
rights reserved.

Permission is granted to copy, distribute and/or modify this
document under the terms of the GNU Free Documentation
License, Version 1.2 or (at your option) version 1.3; with
the Invariant Section being this copyright notice and license.
A copy of the license version 1.2 is included in the section
entitled “GNU Free Documentation License”.

SUSE®, openSUSE®, the openSUSE® logo, Novell®, the
Novell® logo, the N® logo, are registered trademarks of
Novell, Inc. in the United States and other countries. Linux*
is a registered trademark of Linus Torvalds. All other third
party trademarks are the property of their respective own-
ers. A trademark symbol (®, ™, etc.) denotes a Novell
trademark; an asterisk (*) denotes a third-party trademark.

All information found in this book has been compiled with
utmost attention to detail. However, this does not guarantee
complete accuracy. Neither Novell, Inc., SUSE LINUX Prod-
ucts GmbH, the authors, nor the translators shall be held
liable for possible errors or the consequences thereof.

13

http://www.novell.com/documentation/opensuse113
http://www.novell.com/documentation/opensuse113
http://www.kde.org/
http://www.kde-apps.org/
http://www.kde-apps.org/


GNU Free Documentation License
Version 1.2, November 2002

Copyright (C) 2000,2001,2002 Free Software Foundation, Inc. 59 Temple Place, Suite 330, Boston, MA
02111-1307 USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing
it is not allowed.

PREAMBLE
The purpose of this License is to make a manual, textbook, or other functional and useful document
“free” in the sense of freedom: to assure everyone the effective freedom to copy and redistribute it,
with or without modifying it, either commercially or noncommercially. Secondarily, this License preserves
for the author and publisher a way to get credit for their work, while not being considered responsible
for modifications made by others.

This License is a kind of “copyleft”, which means that derivative works of the document must themselves
be free in the same sense. It complements the GNU General Public License, which is a copyleft license
designed for free software.

We have designed this License in order to use it for manuals for free software, because free software
needs free documentation: a free program should come with manuals providing the same freedoms
that the software does. But this License is not limited to software manuals; it can be used for any textual
work, regardless of subject matter or whether it is published as a printed book. We recommend this
License principally for works whose purpose is instruction or reference.

APPLICABILITY AND DEFINITIONS
This License applies to any manual or other work, in any medium, that contains a notice placed by the
copyright holder saying it can be distributed under the terms of this License. Such a notice grants a
world-wide, royalty-free license, unlimited in duration, to use that work under the conditions stated
herein. The “Document”, below, refers to any such manual or work. Any member of the public is a li-
censee, and is addressed as “you”. You accept the license if you copy, modify or distribute the work in
a way requiring permission under copyright law.

A “Modified Version” of the Document means any work containing the Document or a portion of it,
either copied verbatim, or with modifications and/or translated into another language.

A “Secondary Section” is a named appendix or a front-matter section of the Document that deals ex-
clusively with the relationship of the publishers or authors of the Document to the Document’s overall
subject (or to related matters) and contains nothing that could fall directly within that overall subject.
(Thus, if the Document is in part a textbook of mathematics, a Secondary Section may not explain any
mathematics.) The relationship could be a matter of historical connection with the subject or with re-
lated matters, or of legal, commercial, philosophical, ethical or political position regarding them.

The “Invariant Sections” are certain Secondary Sections whose titles are designated, as being those of
Invariant Sections, in the notice that says that the Document is released under this License. If a section
does not fit the above definition of Secondary then it is not allowed to be designated as Invariant. The
Document may contain zero Invariant Sections. If the Document does not identify any Invariant Sections
then there are none.

The “Cover Texts” are certain short passages of text that are listed, as Front-Cover Texts or Back-Cover
Texts, in the notice that says that the Document is released under this License. A Front-Cover Text may
be at most 5 words, and a Back-Cover Text may be at most 25 words.

A “Transparent” copy of the Document means a machine-readable copy, represented in a format whose
specification is available to the general public, that is suitable for revising the document straightforwardly
with generic text editors or (for images composed of pixels) generic paint programs or (for drawings)
some widely available drawing editor, and that is suitable for input to text formatters or for automatic
translation to a variety of formats suitable for input to text formatters. A copy made in an otherwise
Transparent file format whose markup, or absence of markup, has been arranged to thwart or discourage
subsequent modification by readers is not Transparent. An image format is not Transparent if used for
any substantial amount of text. A copy that is not “Transparent” is called “Opaque”.

Examples of suitable formats for Transparent copies include plain ASCII without markup, Texinfo input
format, LaTeX input format, SGML or XML using a publicly available DTD, and standard-conforming
simple HTML, PostScript or PDF designed for human modification. Examples of transparent image formats
include PNG, XCF and JPG. Opaque formats include proprietary formats that can be read and edited
only by proprietary word processors, SGML or XML for which the DTD and/or processing tools are not
generally available, and the machine-generated HTML, PostScript or PDF produced by some word pro-
cessors for output purposes only.

The “Title Page” means, for a printed book, the title page itself, plus such following pages as are needed
to hold, legibly, the material this License requires to appear in the title page. For works in formats which
do not have any title page as such, “Title Page” means the text near the most prominent appearance
of the work’s title, preceding the beginning of the body of the text.

A section “Entitled XYZ” means a named subunit of the Document whose title either is precisely XYZ
or contains XYZ in parentheses following text that translates XYZ in another language. (Here XYZ stands
for a specific section name mentioned below, such as “Acknowledgements”, “Dedications”, “Endorse-
ments”, or “History”.) To “Preserve the Title” of such a section when you modify the Document means
that it remains a section “Entitled XYZ” according to this definition.

The Document may include Warranty Disclaimers next to the notice which states that this License applies
to the Document. These Warranty Disclaimers are considered to be included by reference in this License,
but only as regards disclaiming warranties: any other implication that these Warranty Disclaimers may
have is void and has no effect on the meaning of this License.

VERBATIM COPYING
You may copy and distribute the Document in any medium, either commercially or noncommercially,
provided that this License, the copyright notices, and the license notice saying this License applies to
the Document are reproduced in all copies, and that you add no other conditions whatsoever to those
of this License. You may not use technical measures to obstruct or control the reading or further
copying of the copies you make or distribute. However, you may accept compensation in exchange for
copies. If you distribute a large enough number of copies you must also follow the conditions in section
3.

You may also lend copies, under the same conditions stated above, and you may publicly display copies.

COPYING IN QUANTITY
If you publish printed copies (or copies in media that commonly have printed covers) of the Document,
numbering more than 100, and the Document’s license notice requires Cover Texts, you must enclose
the copies in covers that carry, clearly and legibly, all these Cover Texts: Front-Cover Texts on the front
cover, and Back-Cover Texts on the back cover. Both covers must also clearly and legibly identify you
as the publisher of these copies. The front cover must present the full title with all words of the title
equally prominent and visible. You may add other material on the covers in addition. Copying with
changes limited to the covers, as long as they preserve the title of the Document and satisfy these
conditions, can be treated as verbatim copying in other respects.

If the required texts for either cover are too voluminous to fit legibly, you should put the first ones
listed (as many as fit reasonably) on the actual cover, and continue the rest onto adjacent pages.

If you publish or distribute Opaque copies of the Document numbering more than 100, you must either
include a machine-readable Transparent copy along with each Opaque copy, or state in or with each
Opaque copy a computer-network location from which the general network-using public has access to
download using public-standard network protocols a complete Transparent copy of the Document,
free of added material. If you use the latter option, you must take reasonably prudent steps, when you
begin distribution of Opaque copies in quantity, to ensure that this Transparent copy will remain thus
accessible at the stated location until at least one year after the last time you distribute an Opaque
copy (directly or through your agents or retailers) of that edition to the public.

It is requested, but not required, that you contact the authors of the Document well before redistributing
any large number of copies, to give them a chance to provide you with an updated version of the
Document.

MODIFICATIONS
You may copy and distribute a Modified Version of the Document under the conditions of sections 2
and 3 above, provided that you release the Modified Version under precisely this License, with the
Modified Version filling the role of the Document, thus licensing distribution and modification of the
Modified Version to whoever possesses a copy of it. In addition, you must do these things in the Modified
Version:

A. Use in the Title Page (and on the covers, if any) a title distinct from that of the Document, and
from those of previous versions (which should, if there were any, be listed in the History section of the
Document). You may use the same title as a previous version if the original publisher of that version
gives permission.

B. List on the Title Page, as authors, one or more persons or entities responsible for authorship of
the modifications in the Modified Version, together with at least five of the principal authors of the
Document (all of its principal authors, if it has fewer than five), unless they release you from this re-
quirement.

C. State on the Title page the name of the publisher of the Modified Version, as the publisher.

D. Preserve all the copyright notices of the Document.

E. Add an appropriate copyright notice for your modifications adjacent to the other copyright notices.

F. Include, immediately after the copyright notices, a license notice giving the public permission to
use the Modified Version under the terms of this License, in the form shown in the Addendum below.

G. Preserve in that license notice the full lists of Invariant Sections and required Cover Texts given
in the Document’s license notice.

H. Include an unaltered copy of this License.

I. Preserve the section Entitled “History”, Preserve its Title, and add to it an item stating at least the
title, year, new authors, and publisher of the Modified Version as given on the Title Page. If there is no
section Entitled “History” in the Document, create one stating the title, year, authors, and publisher of
the Document as given on its Title Page, then add an item describing the Modified Version as stated in
the previous sentence.

J. Preserve the network location, if any, given in the Document for public access to a Transparent
copy of the Document, and likewise the network locations given in the Document for previous versions
it was based on. These may be placed in the “History” section. You may omit a network location for a
work that was published at least four years before the Document itself, or if the original publisher of
the version it refers to gives permission.

K. For any section Entitled “Acknowledgements” or “Dedications”, Preserve the Title of the section,
and preserve in the section all the substance and tone of each of the contributor acknowledgements
and/or dedications given therein.

L. Preserve all the Invariant Sections of the Document, unaltered in their text and in their titles.
Section numbers or the equivalent are not considered part of the section titles.

M. Delete any section Entitled “Endorsements”. Such a section may not be included in the Modified
Version.

N. Do not retitle any existing section to be Entitled “Endorsements” or to conflict in title with any
Invariant Section.

O. Preserve any Warranty Disclaimers.

If the Modified Version includes new front-matter sections or appendices that qualify as Secondary
Sections and contain no material copied from the Document, you may at your option designate some
or all of these sections as invariant. To do this, add their titles to the list of Invariant Sections in the
Modified Version’s license notice. These titles must be distinct from any other section titles.

You may add a section Entitled “Endorsements”, provided it contains nothing but endorsements of your
Modified Version by various parties--for example, statements of peer review or that the text has been
approved by an organization as the authoritative definition of a standard.

You may add a passage of up to five words as a Front-Cover Text, and a passage of up to 25 words as
a Back-Cover Text, to the end of the list of Cover Texts in the Modified Version. Only one passage of
Front-Cover Text and one of Back-Cover Text may be added by (or through arrangements made by)
any one entity. If the Document already includes a cover text for the same cover, previously added by
you or by arrangement made by the same entity you are acting on behalf of, you may not add another;
but you may replace the old one, on explicit permission from the previous publisher that added the
old one.

The author(s) and publisher(s) of the Document do not by this License give permission to use their
names for publicity for or to assert or imply endorsement of any Modified Version.

1



COMBINING DOCUMENTS
You may combine the Document with other documents released under this License, under the terms
defined in section 4 above for modified versions, provided that you include in the combination all of
the Invariant Sections of all of the original documents, unmodified, and list them all as Invariant Sections
of your combined work in its license notice, and that you preserve all their Warranty Disclaimers.

The combined work need only contain one copy of this License, and multiple identical Invariant Sections
may be replaced with a single copy. If there are multiple Invariant Sections with the same name but
different contents, make the title of each such section unique by adding at the end of it, in parentheses,
the name of the original author or publisher of that section if known, or else a unique number. Make
the same adjustment to the section titles in the list of Invariant Sections in the license notice of the
combined work.

In the combination, you must combine any sections Entitled “History” in the various original documents,
forming one section Entitled “History”; likewise combine any sections Entitled “Acknowledgements”,
and any sections Entitled “Dedications”. You must delete all sections Entitled “Endorsements”.

COLLECTIONS OF DOCUMENTS
You may make a collection consisting of the Document and other documents released under this License,
and replace the individual copies of this License in the various documents with a single copy that is in-
cluded in the collection, provided that you follow the rules of this License for verbatim copying of each
of the documents in all other respects.

You may extract a single document from such a collection, and distribute it individually under this License,
provided you insert a copy of this License into the extracted document, and follow this License in all
other respects regarding verbatim copying of that document.

AGGREGATION WITH INDEPENDENT WORKS
A compilation of the Document or its derivatives with other separate and independent documents or
works, in or on a volume of a storage or distribution medium, is called an “aggregate” if the copyright
resulting from the compilation is not used to limit the legal rights of the compilation’s users beyond
what the individual works permit. When the Document is included in an aggregate, this License does
not apply to the other works in the aggregate which are not themselves derivative works of the Docu-
ment.

If the Cover Text requirement of section 3 is applicable to these copies of the Document, then if the
Document is less than one half of the entire aggregate, the Document’s Cover Texts may be placed on
covers that bracket the Document within the aggregate, or the electronic equivalent of covers if the
Document is in electronic form. Otherwise they must appear on printed covers that bracket the whole
aggregate.

TRANSLATION
Translation is considered a kind of modification, so you may distribute translations of the Document
under the terms of section 4. Replacing Invariant Sections with translations requires special permission
from their copyright holders, but you may include translations of some or all Invariant Sections in addition
to the original versions of these Invariant Sections. You may include a translation of this License, and
all the license notices in the Document, and any Warranty Disclaimers, provided that you also include
the original English version of this License and the original versions of those notices and disclaimers. In
case of a disagreement between the translation and the original version of this License or a notice or
disclaimer, the original version will prevail.

If a section in the Document is Entitled “Acknowledgements”, “Dedications”, or “History”, the requirement
(section 4) to Preserve its Title (section 1) will typically require changing the actual title.

TERMINATION
You may not copy, modify, sublicense, or distribute the Document except as expressly provided for
under this License. Any other attempt to copy, modify, sublicense or distribute the Document is void,
and will automatically terminate your rights under this License. However, parties who have received
copies, or rights, from you under this License will not have their licenses terminated so long as such
parties remain in full compliance.

FUTURE REVISIONS OF THIS LICENSE
The Free Software Foundation may publish new, revised versions of the GNU Free Documentation License
from time to time. Such new versions will be similar in spirit to the present version, but may differ in
detail to address new problems or concerns. See http://www.gnu.org/copyleft/.

Each version of the License is given a distinguishing version number. If the Document specifies that a
particular numbered version of this License “or any later version” applies to it, you have the option of
following the terms and conditions either of that specified version or of any later version that has been
published (not as a draft) by the Free Software Foundation. If the Document does not specify a version
number of this License, you may choose any version ever published (not as a draft) by the Free Software
Foundation.

ADDENDUM: How to use this License for your documents
To use this License in a document you have written, include a copy of the License in the document and
put the following copyright and license notices just after the title page:

Copyright (c) YEAR YOUR NAME.
Permission is granted to copy, distribute and/or modify this document
under the terms of the GNU Free Documentation License, Version 1.2
or any later version published by the Free Software Foundation;
with no Invariant Sections, no Front-Cover Texts, and no Back-Cover Texts.
A copy of the license is included in the section entitled “GNU
Free Documentation License”.

If you have Invariant Sections, Front-Cover Texts and Back-Cover Texts, replace the “with...Texts.” line
with this:

with the Invariant Sections being LIST THEIR TITLES, with the
Front-Cover Texts being LIST, and with the Back-Cover Texts being LIST.

If you have Invariant Sections without Cover Texts, or some other combination of the three, merge
those two alternatives to suit the situation.

If your document contains nontrivial examples of program code, we recommend releasing these examples
in parallel under your choice of free software license, such as the GNU General Public License, to permit
their use in free software.

Created by SUSE® with XSL-FO
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